Products
  
  
  Crash Magic Online
  
  Intersection Magic
  
  Map Magic
  
  Knowledge Base
  
  
  
  Contact Us
  
  Meeting
  
  Shop
  
  Login
  

 

Knowledge Base Article:CMO295 


Registration keys moved to client area: Select login on the left menu bar.

Knowldegebase:
Search home page  

Firefox fails to display collision diagrams

Article created: Mar 22 2017, updated: Jun 20 2017

Background:  Crash Magic requires Microsoft Silverlight to display and manipulate collision diagrams.  Firefox will no longer display collision diagrams, instead prompting to install Silverlight, but never completing the process.
Info from Mozilla: https://support.mozilla.org/en-US/kb/npapi-plugins


Status:  Limitation - no suggestion
Keywords:  

Silverlight,Firefox ESR,plugin,diagram


Categories:   *Installation and setup* *Errors / crashes* *Diagrams*

Explanation:

Over the years we have supported several different standards for vector graphics as we moved from MS DOS graphics to MS Windows to several iterations of browsers, to now.  It turns out that Microsoft Silverlight, was not one of our better choices for graphics.  The good news is that before Silverlight, there was a technology called SVG and we also invested in that. We still use SVG for all diagram printing, so we know that our engine works well.  Also, SVG has made a nice comeback and is now a part of the HTML5 specification.  There is still some work to do in order to have Crash Magic able to support HTM5 and SVG, but we're working hard on it. When we're done, we will support all modern browsers.

While we always prefer to stay ahead of technology changes, sometimes we miss.  What's important to know is that as always, we will make the necessary changes and keep Crash Magic running for you now and in the future.

We'll do our best to keep you posted, especially if you ask.  Thanks for your patience while we prepare the next major release of Crash Magic!



Solution:

Crash Magic currently relies on Microsoft Silverlight for rendering Collision diagrams.  For the time being, our users will have to use Internet Explorer. 

Note: Firefox has a version called the "Extended Support Release" of their browser for people who still need Firefox to include Silverlight and Acrobat.  If you prefer Firefox and are willing/able to install this version, it is a great solution:

https://www.mozilla.org/en-US/firefox/organizations/all/

Please contact Pd' Programming if you have any questions.


September 18, 2018 7:18PM

© 1999-2018 Pd' Programming, Inc - Lafayette, CO USA