Products
  
  
  Crash Magic Online
  
  Intersection Magic
  
  Map Magic
  
  Knowledge Base
  
  
  
  Contact Us
  
  Meeting
  
  Shop
  
  Login
  

 

Knowledge Base Article:CMO216 


Registration keys moved to client area: Select login on the left menu bar.

Knowldegebase:
Search home page  

Oracle 9i OLE DB driver 9.2.0.7 required

Article created: Apr 15 2010, updated: Apr 15 2010

Background:  Oracle OLE DB 9 drivers less than 9.2.0.7 have a bug which causes metadata to be returned incorrectly. Since this metadata is critical to the functionality of Crash Magic, it is not safe to run with until this patch has been applied. As a result, Crash Magic will refuse to connect and instead report "Please update your Oracle 9i OLE DB driver. Your installed version is: 9.x.x.x".

Status:  Bug - requires upgrade
Keywords:  Oracle 9i,Oracle OLE DB,9.2.0.8
Categories:   *Errors / crashes*

Explanation:

The bug that exists in the earlier 9 drivers causes a request for the list of tables in a schema to incorrectly include SYSTEM tables as well as user tables.  This is a security risk as well as a problem for Crash Magic.

The 9.2.0.7 database and drivers release for Oracle is indicatated as a "Critical Upate" by Oracle.



Solution:

Crash Magic supports Oracle client drivers version 9.2.0.7 and above.  Pd' Programming always recommends using the latest version of all software and drivers.  Usually upgrading to the very latest (i.e. v10) of the Oracle drivers is recommended. However, Oracle has archived versions of the latest drivers for each major release on their website.  As they are not very easy to find, here is a link into the site that works as of April, 2010:

http://www.oracle.com/technology/software/tech/windows/ole_db/index.html


April 25, 2018 10:20AM

© 1999-2018 Pd' Programming, Inc - Lafayette, CO USA